Cherwell Community

Issues with Scheduler after upgrading from 8.1.2 to 9.2.1

Hello

Last week our organization has upgraded to Cherwell 9.2.1 from 8.1.2.  We have had many issues but probably the most concerning is our scheduler.  

1st we are now getting an error that states "The scheduling server cleaned up the item "task name" because it was marked as running but is currently in progress - error occurred"

now we have spoken to cherwell and the swear up and down that this bug was fixed in this version and all we have do is delete and rename the task.  We have done that and still get this error on these long running task.  We have also tried deleting form SQL but still get this error.  We have a ticket with cherwell on this issue but have seen no serious movement.  

2nd issue we are having is that our scheduler is now using significantly more of our CPU then before.  We have a ticket with cherwell with this (after DAYS of push back from them to realize it was a problem).  We have changed relationships, changed timing, and adjusted searches as per recommendations but we have not seen any improvement

Cherwell has not provided any real help.  They swear up and down this is a housekeeping issue and to humor them we played along but all there suggestions have fallen flat.  It is mind boggling that this company is basically telling me that our upgraded version of this software is worse to mange, less efficient, and worse to troubleshoot.  On top of all that we have received little to no help for our upgrade issues (We pretty much have been solving the issues ourselves or coming up with workarounds ourselves)

Any help from anyone would be appreciated